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Toon Boom Studio Importer:
Tour and Tutorial

Toon Boom Studio™ revolutionizes 2D animation production for the Web. With advanced 
drawing, painting, and lip syncing tools, as well as ground-breaking 3D Sceneplanning, Toon 
Boom Studio™ combines the best of traditional animation with innovative tools that will unleash 
your creative potential! 

PutToon Boom Studio™ in your animation toolbox and create fresh, animated, vector content for 
the Web, while respecting the need for modest-sized files. Together with Macromedia® Flash 
MX, you’ll be equipped with a complete production platform for the creation of interactive 
entertainment for the Web.

This document will guide you through the process of using the Toon Boom Studio™ Importer 
to import Toon Boom Studio™ animation content into Macromedia® Flash MX, where you 
can add the interactivity that will WOW your audience of Web viewers.
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Improved Workflow with the Toon Boom Studio 
Importer

The Toon Boom Studio™ Importer for Macromedia® Flash MX is a plug-in that will let you load 
Toon Boom Studio™ projects directly into Macromedia® Flash MX. 

This Importer uses unique technology to improve the communication between Toon Boom 
Studio™ and Macromedia® Flash MX, resulting in a streamlined workflow for adding interactivity 
to animations created in Toon Boom Studio™.
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 Improved Workflow with the Toon Boom Studio Importer 
The Importer gives you full-control of the import process. 

• Select the scenes, elements (layers) and frames, you want to import. 
• Decide how you want to import sound. You can choose to have Toon Boom Studio™ fit 

sounds to your animation to ensure synchronization with the animation in the 
Macromedia® Flash MX movie, or you can choose not to import sounds at all. 

• Preserve the layers in your animation, or collapse your layers into one to keep the effect of 
elements changing relative front-back position (multiplaning).

• Add the entire Toon Boom Studio™ movie to the current scene, or create new scenes for 
each Toon Boom Studio™ scene.

In addition to providing you expert control, the Importer also logically organizes your content in 
Macromedia® Flash MX.

• Element names are preserved as they are transformed into Macromedia® Flash MX 
layers.

• All of your animation content - sounds, bitmaps and drawings - is organized 
automatically in your symbol library so that you can make the most of your content.

• Sounds are placed in their own layer.
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Tour and Tutorial
We’ve put together a Toon Boom Studio™ project and Macromedia® Flash MX movie project to: 

• Show you how to use the Toon Boom Studio™ Importer.
• Demonstrate all of the great creative opportunities now possible because of the new, close 

relationship between these two web animation power houses!
You’ll need two files to follow the tour and tutorial. 

• TBSImport_Phone.tbp: this is the project you will use to tour the features of Toon Boom 
Studio™. You will also import this file into Macromedia® Flash MX to learn how to use 
the Importer.

• TBSImport_Phone.fla: this is a Macromedia® Flash MX project that we constructed by 
importing Toon Boom Studio™ content and programming ActionScript behaviors. You 
can take a look at this file to see what you can do in Macromedia® Flash MX with content 
imported from Toon Boom Studio™.

These two files are in the TBSImporter_Samples folder, which is compressed in the 
TBSImporter_Samples.zip file. To uncompress this file, you’ll need WinZip®, which is available at: 
http://www.winzip.com/

These are also two Macromedia® Flash MX movies in the TBSImporter_Samples folder, saved in 
Macromedia® Flash version 5 and Macromedia® Flash MX format. 

That’s it! You’re ready to go! Turn the page...
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 Tour and Tutorial 
Take the Toon Boom Studio Tour
Our first step in this world wide animation tour is Toon Boom Studio™ where we will take a look 
at the animation project we have built for you.

This animation project contains a whole bunch of goodies, specially designed with the animation 
tools in Toon Boom Studio™. Let’s open her up and take a look inside.

1. Open the TBSImport_Phone.tbp animation set.
• Select File > Open.
• Browse your file system for the location of the animation project we provided you in the 

TBSImporter_Samples folder. All of the windows open in Drawing mode, your work 
space for developing and organizing the content of your animations.

The Drawing View window is your workspace 
for creating vector content. It provides a 
number of digital animation features, including 
onion skin, and Auto and Static Light Table, 
which allow you to see through layers as you 
draw.

The face, arm and hat of this character look 
paler than his body because they are on other 
layers. The Auto Light Table allows you to see 
all of the images in the same frame.

The Tools Palette stores all of the most 
important tools you will need to create and 
edit your vector content. You can also 
conveniently activate these tools with 
configurable keyboard shortcuts.
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2. Open the Scene Manager window. Select Window > Scene Manager if it is not already 
open. Use the Scene Manager to organize your movie into scenes.

This sample movie includes four scenes, which you can view from either Drawing or 
Sceneplanning mode.

3. Open the Doggie scene and click the Color Palette tab in the Properties window.
• Select NightTime from the Style drop-menu. Notice how the color of the doggie changes, 

becoming darker for a nighttime scene. You can create different palette effects in palette 
styles and apply the effects automatically to drawings that use the colors in the palette.

• Select the DayTime palette style from the Style drop-menu to return the doggie to his 
daytime colors.

Double-click a scene name to open 
it and explore its contents.

You can hide a scene from your 
movie by de-selecting its 
Show/Hide button.

The Color Palette tab organizes all of the colors for 
your production. 

You can create different 
palettes for each element, 
which can help you organize a 
complex scene with lots of 
different animated 
characters.

You can create different palette 
styles for each palette.

When you change palette styles, the 
colors in the drawings that use the 
color swatches in that palette 
change to reflect the properties of 
the active style.
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4. Open the Guy scene again, and open and study the Exposure Sheet window. 

The Exposure Sheet window organizes all of the media in your animation. It is your asset 
library for the bitmaps, sounds, vector images, and movies, you import into Toon Boom 
Studio™. 

Toon Boom Studio™ provides a number of ways for you to get content into your movie, 
including the ability to import and vectorize bitmap images that you scan. This particular 
feature enables you to use drawings you created with traditional pen and paper techniques in 
your Toon Boom Studio™ animated movies.

In the Exposure 
Sheet, columns store 
the content of a 
unique animation 
element, such as the 
body of a character 
or background bitmap 
images.

Each new drawing or 
image in an animation 
element is stored in a 
new cell. 

Rows span entire 
elements, 
representing the 
visual content of your 
movie at a specific 
frame.
  9
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5. In the Exposure Sheet window, scroll to the Sound element and click the Toggle 

Thumbnails  button so that you see thumbnails of your content in the Exposure Sheet. 

See the lip chart? This was 
automatically generated by Toon 
Boom Studio™. 

• Toon Boom Studio™ 
analyzes voice tracks and 
generates lip charts 
automatically for you! 

• You can use the lip chart as 
a reference while you draw 
the lips of your characters 
as they speak. Automatic lip 
sync analysis saves you tons 
of time when working out 
the lip sync for your 
characters.
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6. Open the Template Browser window. Select Window > Template Browser if it is not 
already open.

The Template Browser stores reusable content. 
• Content you can share within the current animation is stored in the Local folder. 
• Content you can share with any animation project is stored in the Global folder.

You can copy or link templates into your animation. When you link templates, you keep the 
file size of your Macromedia® Flash MX movie small because only one file is copied into the 
final SWF.

You can build 
templates from 
vector drawings 
or from just 
about any media 
you import.

You can also add 
catalogs to track 
and organize 
reusable 
templates.
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7. Switch to Sceneplanning  mode. Look at the Camera View, Top View and Side View 
windows. Notice the camera framing and the motion path that the camera follows through 3D 
space. 

Sceneplanning mode is an important innovation in 2D animation. It gives animators the 
ability to lay out 2-dimensional objects in a 3D space (x, y AND z!). In the 3D space you can 
also use pegs to move, rotate, and scale elements, as well as create various camera effects! 

Think of Sceneplanning mode as a 3D stage where the elements are actors that you move on 
the stage, changing the perspective that your audience has of your scene. Toon Boom 
Studio™ automatically calculates (interpolates) changes for you, which speeds your 
production time enormously!

The Camera View window shows you how 
your scene looks from the eye of the 
camera. The frame in this window 
represents the view of the camera.

In the Side View and Top View windows, 
elements are identified as lines and the 
camera is indicated by the cone shape lines.

• The Side View window shows you how 
your scene elements look from the side. 

• The Top View window shows your scene 
elements as they appear from the top 
looking down.

We have zoomed and 
panned these windows to 
create what you see 
here in these pictures.

• To zoom-out, 
press [Z], the 
default keyboard 
shortcut.

• To pan, press the 
[Spacebar] and 
use the hand to 
change your view 
of the window.
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8. In the Timeline window, select the Phone element. You’ll notice that the information in the 
Properties window changes.

In Sceneplanning mode, the 
Timeline window helps with the 
organization of your animation, 
allowing you to track the timing of 
your elements as well as group 
elements together.

In this scene, the phone and camera 
are attached to a peg, which moves 
them through the scene.

The Properties window displays information about 
the element you select.

We set the phone element as a Foreground element 
type so that no matter what changes occur to the 
layering order of elements in Sceneplanning mode, 
the phone will always appear on top.
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9. Switch to the Doggie scene and press Play  on the Interactive Playback toolbar. Watch 
the dog as he runs around the ball, moving in front of and behind the ball. Interactive 
Playback allows you to perform quick checks of the action in your scene as you work on it. 
Interactive Playback is not a real-time check, which you will see in the next step.

We created a motion path with the Dog Peg element that moves the dog around the ball. Not 
only will Toon Boom Studio™ reorder the objects as they change relative position, but it will 
also automatically calculate and resize (interpolate) the dog based on his relative position to 
the camera in Sceneplanning mode. 

Pegs and the 3D stage in Sceneplanning mode really save a lot of time when it comes to 
mapping your character movements.

See how the element line 
of the dog moves around 
the element line of the 
ball.

Look at that doggie go!
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 Tour and Tutorial 
10. Preview the animation in real-time. Check-out the multiplane camera move and the 
multiplane motion of the dog!
• Select Play > Play Movie. After your movie is rendered, it appears in the Playback 

window. The Play Movie and Play Scene commands play back your animation in real-
time so that you can check the timing of your animation as it will play in its final form.
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11. Now you are ready to export your animation. You can export in Macromedia® Flash MX 
format to keep the file size of your animation small for output to the web. Or, you can output 
in QuickTime® format to control the aspect ratio and resolution of your animation.

You’ll export your animation in Macromedia® Flash MX format in these steps.
• Select File > Export > Macromedia Flash Movie. The Save As dialog box opens.
• Select a name and location for your Macromedia® Flash MX movie and click Save. The 

Export as a Macromedia Flash movie dialog box opens.
• Select Full Movie, Launch player after export, leave the JPEG quality setting as it is, 

and click OK. A progress dialog box opens during the rendering process. When the render 
is complete, a window opens and your movie is played.

After the camera trucks out on the golfing guy, there are three more scenes that follow. In 
Macromedia® Flash MX you can add interactive controls to the buttons on the cell phone so 
that when users click the buttons, they will see the other scenes in the movie.

That’s it for the Toon Boom Studio™ tour. Turn the page to follow the Toon Boom Studio™ 
Importer tutorial.
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 Tour and Tutorial 
Toon Boom Studio Importer Tutorial
Now that you’ve seen all of the neat stuff we’ve done with the animator-friendly tools in Toon 
Boom Studio™, you are ready to import the animation project into Macromedia® Flash MX to add 
interactivity.

You will import the whole movie into Macromedia® Flash MX, but you are going to do it in two 
steps.

• First you are going to import the first three scenes of the movie using the Preserve 
Layers option. This option converts Toon Boom Studio™ elements into separate layers. 
This maintains the organization of your project, but looses changes to the composition 
order of objects when they change relative front-back position.

• Then, you are going to import the last scene using the Preserve Composition Order 
options. This option merges all of the layers of a scene to one, but maintains changes to the 
relative position of objects that move from front to back.

We’ll explain the power of both of these options, and the reason you would choose one over the 
other, in the following two sections.
  17



Toon Boom Studio  Importer: Tutorial and Tour
Importing Using the Preserve Layers Option
The Preserve Layers option converts Toon Boom Studio™ elements into layers in the 
Macromedia® Flash MX Timeline, preserving the name and layering order of your animation. 
However, this option does not preserve composition order of objects that cross in front of each 
other as they change relative positions in depth.

So why would you choose this option?

• If your scene contains only camera effects, such as zooms, pans and trucks, you can use 
this option and still preserve your camera effects. 
Characters in the camera frame will appear to grow, shrink, or fly by, and your elements 
will be logically ordered in the Timeline.

In the tutorial movie, there are four scenes, three of which have camera moves only. In this section, 
you will import these scenes using the Preserve Layers option to see what happens.

In the first scene, the camera 
zooms out on the golfing guy.

This camera effect is preserved when you import using the Preserve Layers 
option because no objects change their relative front/back position.
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 Tour and Tutorial 
To import a Toon Boom Studio™ project using the Preserve Layers option, follow these steps:

1. Start Macromedia® Flash MX. A new project is created automatically.

2. Select File > Import. The Import dialog box appears. 

3. From the Files of Type drop-list, select Toon Boom Studio. Toon Boom Studio™ animation 
sets have the extension .TBP. 

4. Select the TBSImport_Phone.tbp animation set from the TBSImport_Samples folder and click 
Open. The Toon Boom Studio Importer dialog box opens.
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5. Select the first three scenes (Guy, Cowboy and toonBoom). Toon Boom Studio™ imports all 
elements and frames when you select multiple scenes. 

6. Select Import sounds. When you select the Apply sound edits option, the Toon Boom 
Studio™ Importer modifies the sound files to include the effects (like fade envelopes and 
start/stop time) you create in Toon Boom Studio™. In this case, we did not modify the 
sounds, so you don’t have to select this option.

7. Select Preserve layers. We have a camera move in the sample scene, no scene elements 
change relative position order, so Preserve composition order is the best option.

8. Select Create new scenes in the Output Options panel. This option adds the scenes you 
import after the current scene. If you do not select this option, the Importer will add all of the 
content you import into the current scene.

9. Click OK when you are done. A progress dialog box opens as the Toon Boom Studio™ 
importer begins working to transform your animation set content. 

10. When the import is done, open the imported scenes.

The Importer adds the three scenes after the first scene in the movie. You must delete this scene, 
otherwise you will have a blank scene in your move.

The Toon Boom Studio™ importer adds 
your animation set after the current 
scene. To see the Toon Boom Studio™ 
content you have imported, you must open 
the appropriate scene.
20  



 Tour and Tutorial 
11. Take a look at the Timeline and Library to see how your movie was imported.

That’s it for this part of the tutorial. The next step is to import the last scene into your movie. 
See “Importing Using the Preserve Composition Order Option” on page 22.

Notice how all of your elements have been transformed into 
Macromedia® Flash MX layers, keeping their name in the 
process. The camera move has been recreated in 
Macromedia® Flash MX by changing the relative size of 
objects on their layers.

Notice the Symbol Library. All of the unique 
content in your Toon Boom Studio™ animation has 
been stored in the Symbol Library. You can easily 
access these library items now, and reuse them to 
keep the file size of your movie small. 
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Importing Using the Preserve Composition Order Option
The Preserve Composition Order option merges all of your animation elements into one layer, 
maintaining changes to objects that change relative front-back position. 

Because the Importer merges element into one layer with this option, it is a little more difficult to 
organize and track elements. So why would you choose this option?

• If you have finished building all of your animation elements and your scene contains 
multiplane effects, then use this option. If all you are doing in Macromedia® Flash MX is 
adding buttons and scripting effects, you can easily create new layers for those in the 
movie.

In the Doggie scene, the dog runs around the ball, changing relative front-back position with the 
ball each time he circles it. 

In this section, you will import these scenes using the Preserve Composition Order option and 
see how your multiplane effect is preserved.

In the Doggie scene, the effect of the dog running in front 
of and behind the ball is maintained when you import using 
the Preserve Composition Order option.
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To import a Toon Boom Studio™ project using the Preserve Composition Order option, follow 
these steps:

1. Make the TBS toonBoom scene active. The Importer will add the new scene after the active 
scene.

2. Select File > Import. The Import dialog box appears. 

3. From the Files of Type drop-list, select Toon Boom Studio. Toon Boom Studio™ animation 
sets have the extension .TBP. 
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4. Select the TBSImport_Phone.tbp animation set from the TBSImport_Samples folder and click 
Open. The Toon Boom Studio Importer dialog box opens.
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5. Select the last scene (Doggie), and all elements and frames.

6. Select Import sounds. The doggie barks, but we didn’t modify the barking sound in Toon 
Boom Studio™, so you don’t have to select the Apply sound edits option.

7. Select Preserve Composition Order. We want to preserve the effect of the dog running 
around the ball.

8. Select Create new scenes in the Output Options panel.

9. Click OK when you are done. A progress dialog box opens as the Toon Boom Studio™ 
importer begins working to transform your animation set content. 

10. When the import process is finished, open the Doggie scene.

The Toon Boom Studio™ importer adds the 
Doggie scene after the TBS toonBoom 
scene.
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11. Take a look at the Timeline and Library to see what happened to the scene.

12. Press [Enter] and playback the Doggie scene to see how he runs around that ball!

With your content now in Macromedia® Flash MX, you can add scripting to create an 
interactive, animation environment for your viewers. 

Check-out “Adding Interactivity in Macromedia® Flash™ MX” on page 27 to see how you 
can use scripting to add interactivity to your Macromedia® Flash MX movie.

The importer adds the animation content in the 
Doggie scene to the Library.

All of the elements in the Doggie scene get 
merged into one layer to maintain the effect of 
the doggie running in front of and behind the ball.
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Adding Interactivity in Macromedia® Flash™ MX
So now that you’ve seen how the Toon Boom Studio™ Importer for Macromedia® Flash MX can 
improve the workflow, we are going to show you a Macromedia® Flash MX project. In this project, 
we took content we developed in Toon Boom Studio™ and added interactivity.

1. In Macromedia® Flash MX, open TBSImport_Phone.fla from the TBSImport_Samples folder.

2. Open the Scene window.

3. Navigate through the different scenes in the movie.
• You’ll notice that there is a Stop action on the last frame of every scene. This is the script 

we used:
stop();

• You’ll also notice that there are actions linked to the cell phone buttons that will take users 
to the other scenes in the movie when they are clicked. This is the script we used:

on (release) {
gotoAndPlay ("[sceneName]", [frameNumber]);
} 

4. Export the movie. Watch! Interact! Enjoy! Witness how we were able to construct an 
interesting animation using the unique features of both Toon Boom Studio™ and 
Macromedia® Flash MX.

Here are some other ideas for what you can do with content developed in Toon Boom Studio™:

• Add interactive buttons that launch camera moves that zoom in and out on characters.
• Add interactive buttons that launch a character into a long-winded speech, which you can 

lip sync with ease in Toon Boom Studio™.
• Create multiplane scenes in Toon Boom Studio™ that are accessible only through 

programmed interaction. 
You can even create your own “choose your own adventure” story that moves players 
through a world of multiplane effects, like riding in planes, trains and bicycles!

The possibilities are endless now that the technology is in place for improved communication 
between Toon Boom Studio™ and Macromedia® Flash MX. Toon Boom Studio™ and 
Macromedia® Flash MX - the perfect couple!
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Additional Information and Resources
Getting the Importer and Importer Updates

The Toon Boom Studio™ Importer is provided with Macromedia® Flash MX. We will also make 
updates of the Importer available on our website. 

Be sure to visit http://www.toonboomstudio.com/flashmx for product updates, as well as 
product information.

Getting Toon Boom Studio
You must have Toon Boom Studio™ installed on your computer to take the Toon Boom Studio™ 
tour and of course, to create your own Toon Boom Studio™ toons. 

An evaluation of Toon Boom Studio™ is distributed with Macromedia® Flash MX. You can also 
get the latest evaluation version for free from the Toon Boom Studio™ website.

Getting your free evaluation copy of Toon Boom Studio™ is as easy as pie. Just follow these steps:

1. You must first become a member of the Toon Boom Studio™ website. 
Go to http://www.toonboomstudio.com/members/ and sign-up. 

Remember the email address and password you use to become a member. You will be asked 
for both when you log-in to the website.

2. After you are a member, go to the Store (http://www.toonboomstudio.com/store) and 
follow the links to download the evaluation copy.

That’s it! You are ready to install and run the Toon Boom Studio™ tour!
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 Additional Information and Resources 
Toon Boom Studio Documentation
Need more detailed information about Toon Boom Studio™, how it works and its features? 

Toon Boom Studio™ comes equipped with Online Help, which can help you answer questions 
quickly. Just press [F1] and the fully-indexed and searchable Online Help will open in your default 
web browser.

For more detailed explanations of procedures and concepts, and illustrated examples, you may also 
refer to the User Guide, which is also available as a PDF, downloadable from our website: 
http://www.toonboomstudio.com. Those of you who purchase the box version get a printed 
version of the manual, one that you can read on the subway or train to work, or while resting at 
home on the weekends.

There are also tutorials available from our website at:
 http://www.toonboomstudio.com/tutorials/
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